Upgrade

It is recommended customers with ServiceNow Connector upgrade to the latest release. (Connector 2019.10.0)

Perform if upgrading from a previous version of SovLabs ServiceNow Connector

1) Install SovLabs Plug-in 2019.10.0

  • The SovLabs ServiceNow Connector release 2019.10.0, needs at minimum SovLabs Plug-in 2019.10.0
  • Requires a 2019.x SovLabs License key

2) Determine which version of the SovLabs ServiceNow Connector that is currently installed

  • In ServiceNow instance, type in “Retrieved Update Sets” in the left pane
  • Find the SovLabs Connector Update Set(s) that is/are “Committed” by searching ‘Retrieved Update Sets’ and look for the ‘newest’ version.
Update Sets Screenshot
  • If there is a SovLabs Connector Update Set 2019.8.0, then ONLY the SovLabsConnector-2019.10.0-upgradeFrom-2018.8.0.zip is required
  • If there is a SovLabs Connector Update Set 2018.1.7, the SovLabsConnector-Upgrade2018.1.7to2018.3.0.1.zip is required
    • Then, SovLabsConnector-2019.8.0-upgradeFrom-2018.3.0.1 is required
  • If there is a SovLabs Connector Update Set committed on or after May 29, 2018, the SovLabsConnector-Upgrade2018.1.6to2018.3.0.1.zip is required
    • Then, SovLabsConnector-2019.8.0-upgradeFrom-2018.3.0.1 is required
  • If a SovLabs Connector Update Set was installed before May 29, 2018, please contact support@sovlabs.com

Note: It is possible to need to install multiple Update Sets sequentially in order to go from older versions (2018.1.x) to 2019.10.0+

3) When committing an upgrade Update Set, please Accept Remote Update when running a Preview and then Commit.

4) Please reboot the primary Mid Server for ServiceNow Connector after an upgrade.

5) A new prerequisites is required for versions 2018.3.0.1 and above. Set All Application Access for table with name: question_choice (Label: Question Choice):

  • Go to System Definition > Tables > question_choice
  • Go to Application Access
  • For All application scopes, make sure Can read, Can create, Can update, and Can delete are checked

6) To Validate the Update Set and SovLabs Application are installed correctly in ServiceNow do the following:

  • In ServiceNow instance, type in “Retrieved Update Sets” in the left pane * Find the SovLabs Connector Update Set(s) that is/are “Committed” *
  • Rerun the SovLabs Installation Wizard and validate all checks pass. Browse to SovLabs > Installation Wizard. Click Begin Installation to run the Wizard in the new browswer tab.
SovLabs Installation Wizard Screenshot


Note: If desired, previous Update Sets can be removed via the docuemented back-out Process UpdateSet Removal.